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OmegaT Translation guide
TIP:

If you want to make use of Table of Contents, in order to jump from one section to another more easily, refer to 
KnowSystem navigation guide > Table of contents section .

OmegaT

OmegaT is the free and open source (FOSS) Computer-Assisted Translation tool (CAT tool), used for translation,
reconciliation, adaptation, proofreading and verification. The software has been customized to enable you to
perform your task.

For OmegaT installation and customisation, click the link below at the end of this user guide.

Unpack OmegaT package
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The following steps need to be performed only once per OmegaT package.

1. Download the OMT package (from a location designated by the cApStAn project manager)
2. Store the OMT package in a location you will remember on your computer
3. Unpack the OMT package in OmegaT

To do so:

Open OmegaT
Go to Project>Unpack project from OMT file

Navigate to the location where you stored the OMT package. Choose the OMT package and click Open.
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Open the project

Once you have unpacked a project, the next time you will be able to open it by going to Project>Open Recent
Project. The project you were working on last (the most recently updated) is the first one in the list.

Navigation

Navigation between the different panes
When you open OmegaT, you will notice that the screen is split in several panes:

The Editor pane is the main pane in which you will be working
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Translation suggestions from the translation memory will appear in the Fuzzy Matches pane as you
translate
The Glossary pane will display the definitions of key terms and their equivalent in the target language
The Multiple translations pane will show you if a repeated segment was translated differently

Navigation between segments
In the editor pane, the active segment is highlighted in green. This is the segment you are working on. When you
type or insert a translation, it will appear below the source text. 

Press the Enter key on your keyboard to go to the next segment. A segment can also be activated by double
clicking on it. It then gets highlighted in green .

In OmegaT, a color code will help you find your way around between the different segments:

Green = the segment you are working on (active segment)
Blue = untranslated segment
Grey = translated segment. The translation is displayed below the source text.
Orange  = pre-translated and locked segment. 
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Navigation between files
If the project contains multiple files, they are listed in the Project Files pane. The file currently open is highlighted
in blue. 
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Handlin tags (Ctrl +T)

Recognising tags
If you are in a segment which contains tags, you will recognize them because they are in red font.

There are two types of tags - standalone tags and double tags:

Standalone tags = a single tag with a precise role (e.g. <br/> tag which introduces a new paragraph in
HTML)
Double tags are composed of an opening and a closing tag, such as the HTML tags for making text bold,
italic, underlined, etc. Double tags affect the text between them and you need to ensure they are positioned
around the exact same words in the source and in the translation.

 

Inserting tags
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To insert tags in your translation, you should use the keyboard shortcut Ctrl+T, which inserts the next missing
tag.

Note that tags are inserted in the order of their appearance in the source segment. If you need to insert tags in a
different order than in the source, we advise you to translate the entire segment, place your cursor where the first
tag has to be inserted and press Ctrl+T, then repeat the operation until all tags have been inserted.

If you have inserted a tag incorrectly and need to delete it, select the tag in full (you can double click on it) and press
backspace or delete on your keyboard.

Most common HTML tags
Below you will find the most common HTML tags you may encounter.

Using Fuzzy Matches (Ctrl+I)

When you translate, your translations are saved in the project’s translation memory. When you activate a
segment which is similar to one you have already translated, you will see suggestions appearing in the fuzzy
matches pane.

The source in the fuzzy matches pane shows the difference between the active segment and the previous
translation in “track changes” mode like in Word:

Parts that do not appear in the active segment are in red font and stricken through 
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Parts that are added are in blue font and underlined

When there are several fuzzy matches for a segment, they are sorted by similarity to the new segment. The active fuzzy
match is the one in bold. By default, it will be the first one in the list. If you want to use a different fuzzy match, double
click on it to activate it.

To insert the fuzzy match in full, press Ctrl+I on your keyboard. After inserting it, do not forget to make the
necessary changes so that it fits the segment you are translating.

Alternatively, you can also insert only a part of the fuzzy match or combine several matches:

Activate the match you want use
With your mouse, select the part you wish to insert
Press Ctrl+I on your keyboard to insert it
Select another fuzzy match if appropriate or finish translating the segment
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Using the Glossary

OmegaT supports glossaries. Your package may already contain a glossary with key terms, but you can also add
terms to the glossary yourself.

Inserting glossary terms
When you arrive in an active segment which contains a glossary term, the respective term is underlined in blue in
the source segment. You will see the suggested target term in the Glossary pane, on the right. 

OmegaT has predictive typing: when you start typing the first character of the target term in the glossary, the
auto-completer will suggest the term. To insert it, press Enter on your keyboard.
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Adding terms to the glossary
If the project you are working on contains technical terms or you notice certain terms keep repeating, you can add
them to the glossary. To add a term:

In the active segment, select the term you want to insert with your mouse
Right click and choose Add glossary Entry from the contextual menu

A pop-up window will open.
Enter the target term and press OK.  

Handling repeated segments

Identifying repeated segments
You can recognize that you are in a repeated segment because it has gray font. When a repeated segment is
active, the segment number will indicate how many repetitions exist: 
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Autopropagation
If you edit the translation of a repeated segment, by default, the changes will be automatically reflected in all
the repetitions. This happens in the same file, but also in all the files of the OmegaT package.

Create alternative translation
In some cases, you may not wish to modify the translation of all repeated segments. Due to a different context,
you may need to change only ONE of the repeated segments:

Right click on the segment
Choose Create Alternative Translation from the contextual menu:

x
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When you return to the repeated segment, you will see the different translations appear in the Multiple
Translations pane:

Other useful feature

Inserting source segment in target
In some cases, the translation and the source segment must be identical. To insert the source text in the target
segment, press Ctrl+Shift+S on your keyboard. 
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You can also copy & paste the source text into the target.

Leaving a segment empty
All segments of the OmegaT package must have a translation. If you leave a segment empty, the source text will be
displayed in the final document. If you wish the segment to remain empty, insert a space in the target segment instead
of the actual translation. 

Character table
Special characters can be inserted with the Special Characters Table. Special characters can be:

quotation marks: «», „“, ‘’, etc.
mathematical symbols: ×, π, ÷, ≤, ≠, √, etc.
other characters: ®, ™

When you arrive in a segment in which you need to insert a special character, perform the following steps:

Press Ctrl+Space on your keyboard several times until you reach the special characters table.

Select the character you want to insert
Press Enter and continue editing your segment.

Concordance searches (Ctrl + F)
A concordance search allows you to look for words and expressions in the translation memory and the glossary.
To perform a search follow the steps below:

In the active segment, select the word you want to search for with your mouse.
Press Ctrl+F on your keyboard.
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The Search window will open.
Press Search. The results will be displayed.
You can double click to go to the segment (shaded in green on the screenshot below).
You can copy (select with mouse and press Ctrl+C on your keyboard) what you need from the results and
paste it in the target translation at the right place.

Tip: There might be small differences (in punctuation, spacing, etc.) between the text you're searching for and
other occurrences of the same text that would prevent an exact match. The option “Keyword search” might help
overcome that problem, please use it if you don't get the results you were expecting.

Performing QA checks in OmegaT

Completion check
All segments of the OmegaT package must have a translation. To ensure that is the case, please check for
completion prior to delivery:

Go to Project>Project Files
The project files pane will open
OK: If the Number of unique segments is equal to the number of Translated unique segments.

NOT OK: the Number of unique segments is different from the number of Translated unique segments. To
correct this:

1. Close the Project Files Pane
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2. Press Ctrl+U on your keyboard to jump to the Next Untranslated Segment.
3. When the cursor stops moving from the active segment then all segments have a translation.
4. Check again in the the Project Files pane as described above.

Check and fix tags
To ensure that all tags have been inserted correctly:

Go to Tools>Check Issues. A pop up window will open.

By default, other types of checks (Spelling, Terminology, LanguageTool) are ticked. If you want to check
for issues related to tags before performing the rest of the checks, you can untick them. You will notice that
the Tag Issues box cannot be unticked.

Press OK. An error report will open:

Go through the issues one by one:

1. Correct the issue by clicking on Jump to Segment. You will arrive at the appropriate segment in the editor
pane.

2. Place your cursor where the missing tag needs to be inserted and press Ctrl+T to insert the missing tag.
3. Press Enter to move to the next segment.
4. Open the Error report again. (It has automatically refreshed).
5. Finish going through the issues.
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TIP: If in the source there are tags that you do not use in your language which are present in the source segment,
to avoid having false positives in the error report, you can insert them at the end of the segment. They would not
have an impact on any text.

CAUTION: Please do NOT click on “Apply fix”, fix each issue manually.

Spellcheck
Perform a spellcheck. To do that:

Go to Options>Preferences. A pop-up will open. Click on Spellchecker.

  If your target language is not already displayed, click on 'Install new dictionary', select the language from the list
that appears and click on Install.

If your target language is not in the list, it means there is no spellchecker for their language.
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Creating target files

Press Ctrl+Shift+D to create the target file you were working on. This will allow you to preview the translated file
with your changes.

To access the file, go to Project>Access Project Contents>Target Files.

A window with the contents of the “target” folder will open. Find the file you were working on, if there are several
files and preview it to read the translation in context.

Creating OMT package for delivery

To create the OMT package for delivery, go to Project>Pack Project as OMT file.

The OMT Package will be created and the folder where you can find it will automatically open.

Related articles
OmegaT installation and customisation guide
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